Exit code 60008 when deploying with ConfigMgr

//Exit code 60008 when deploying with ConfigMgr
Exit code 60008 when deploying with ConfigMgr2018-03-20T13:14:59+00:00

The Toolkit Forums General Exit code 60008 when deploying with ConfigMgr

  • Author
    Posts
  • Sven
    Participant
    Post count: 1

    Hi all,

    I’ve successfully used PADT in the past with different customers without issues. I must say, I love it 🙂
    I’m currently trying to install the ConfigMgr Console with PADT with a new customer and the installation with ConfigMgr keeps failing on 60008.

    I’ve verified the following:
    – “Client Settings” in ConfigMgr will execute POSH scripts with Executionpolicy Bypass
    – User Experience: “Install for System”, “Wether or not a user is logged on” and “Hidden”

    I’ve tried the following:
    – Tried executing it manually with an administrator account ==> OK
    – Tried executing it manually with PSEXEC ==> NOK
    – Installation done without parameters and parameter : -DeploymentType “Install” -DeployMode “Silent” with SCCM ==> NOK
    – Tried executing the PS1 file instead of “DeployApplication.exe” with the same issue presents itself.

    Any ideas what might be wrong? In the past I’ve had no issues using the same script in combination with SCCM. We’re running SCCM CB 1710 with the latest hotfix and I’m using the latest version of PADT.

    PADT Logfile:
    [Initialization] :: ******************************************************************************* PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: ******************************************************************************* PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: [Microsoft_ConfigMgrConsole_5.00.8577.1000_EN_01] setup started. PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: Script [C:\windows\ccmcache\1e\AppDeployToolkit\AppDeployToolkitMain.ps1] dot-source invoked by [C:\windows\ccmcache\1e\Deploy-Application.ps1] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: Script [C:\windows\ccmcache\1e\AppDeployToolkit\AppDeployToolkitExtensions.ps1] dot-source invoked by [C:\windows\ccmcache\1e\AppDeployToolkit\AppDeployToolkitMain.ps1] PSAppDeployToolkitExt 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: [Microsoft_ConfigMgrConsole_5.00.8577.1000_EN_01] script version is [1.0.0] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: [Deploy Application] script version is [3.7.0] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: [App Deploy Toolkit Main] script version is [3.7.0] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: [App Deploy Toolkit Extensions] version is [1.5.0] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: Computer Name is [computer.domain.local] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: Current User is [NT AUTHORITY\SYSTEM] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: OS Version is [Microsoft Windows 10 Enterprise 64-bit 10.0.16299.98] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: OS Type is [Workstation] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: Current Culture is [nl-BE], language is [NL] and UI language is [NL] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: Hardware Platform is [[03-20-2018 13:27:53.691] [Initialization] [Get-HardwarePlatform] :: Retrieve hardware platform information. Physical] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: PowerShell Host is [ConsoleHost] with version [5.1.16299.98] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: PowerShell Version is [5.1.16299.98 x64] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: PowerShell CLR (.NET) version is [4.0.30319.42000] PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)
    [Initialization] :: ******************************************************************************* PSAppDeployToolkit 20/03/2018 13:27:53 9840 (0x2670)

    When running with PSEXEC and admin credentials, the following is also displayed in the console:
    C:\Windows\ccmcache\1i\Deploy-Application.ps1 : Module [C:\Windows\ccmcache\1i\AppDeployToolkit\AppDeployToolkitMain.ps1] failed to load:
    Cannot convert value “[03-20-2018 14:07:26.802] [Initialization] [Get-RegistryKey] :: Registry key [[03-20-2018 14:07:26.799] [Initialization
    ] [Convert-RegistryPath] :: Return fully qualified registry key path [Registry::HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MUI\Settings].
    Registry::HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MUI\Settings] does not exist. Return $null.” to type “System.Globalization.CultureI
    nfo”. Error: “Cultuur wordt niet ondersteund.
    Parameternaam: name
    [03-20-2018 14:07:26.802] [Initialization] [Get-RegistryKey] :: Registry key [[03-20-2018 14:07:26.799] [Initialization] [Convert-RegistryPat
    h] :: Return fully qualified registry key path [Registry::HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MUI\Settings]. Registry::HKEY_LOCAL_
    MACHINE\SOFTWARE\Policies\Microsoft\MUI\Settings] does not exist. Return $null. is een ongeldige cultuuridentificatie.”

    At C:\Windows\ccmcache\1i\Deploy-Application.ps1:98 char:81
    + … yToolkitMain -DisableLogging } Else { . $moduleAppDeployToolkitMain }
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Deploy-Application.ps1

    AppEnforce logfile (SCCM):
    App enforcement environment:
    Context: Machine
    Command line: Deploy-Application.exe
    Allow user interaction: No
    UI mode: 0
    User token: null
    Session Id: 1
    Content path: C:\windows\ccmcache\1e
    Working directory: AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Prepared working directory: C:\windows\ccmcache\1e AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Prepared command line: “C:\windows\ccmcache\1e\Deploy-Application.exe” AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Executing Command line: “C:\windows\ccmcache\1e\Deploy-Application.exe” with user context AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Working directory C:\windows\ccmcache\1e AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Post install behavior is BasedOnExitCode AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Waiting for process 7784 to finish. Timeout = 30 minutes. AppEnforce 20/03/2018 13:27:47 1252 (0x04E4)
    Process 7784 terminated with exitcode: 60008 AppEnforce 20/03/2018 13:27:54 1252 (0x04E4)
    Looking for exit code 60008 in exit codes table… AppEnforce 20/03/2018 13:27:54 1252 (0x04E4)
    Unmatched exit code (60008) is considered an execution failure. AppEnforce 20/03/2018 13:27:54 1252 (0x04E4)
    ++++++ App enforcement completed (7 seconds) for App DT “SCCM_console” [ScopeId_E778B182-4287-4383-91E0-C9F34D7B4C72/DeploymentType_3bd9e1db-add4-4a95-8535-12f5ea1fa626], Revision: 3, User SID: ] ++++++ AppEnforce 20/03/2018 13:27:54 1252 (0x04E4)

    Thanks!

    • This topic was modified 3 months, 4 weeks ago by  Sven. Reason: Additional information
  • Brian
    Participant
    Post count: 6

    This has always worked for me. See URL, not allowing inline image

    • This reply was modified 2 months, 4 weeks ago by  Brian.

You must be logged in to reply to this topic.