get-installedapplication throws error

//get-installedapplication throws error
get-installedapplication throws error 2017-01-19T05:02:24+00:00

The Toolkit Forums General get-installedapplication throws error

  • Author
    Posts
  • Kyle
    Participant
    Post count: 14
    #1846 |

    I am new to PS and the PSADTK.

    When try to use Get-InstalledApplication, it just throws an error, as seen below. This happens on all of the computers i have tried it on thus far.

    Any help would be appreciated, thank you!

    Get-InstalledApplication : The term ‘Get-InstalledApplication’ is not recognized as the name of a cmdlet, function,
    script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is
    correct and try again.
    At line:1 char:1
    + Get-InstalledApplication -name ‘google chrome’
    + ~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : ObjectNotFound: (Get-InstalledApplication:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

  • Seán Lillis
    Keymaster
    Post count: 16

    It looks like you are not using the Deploy-Application.ps1 template. Since the Get-InstalledApplication cmdlet is in the first line of your script, the toolkit has not been dot-sourced and thus the cmdlet is not recognized. Please refer to the documentation that comes with the toolkit or alternatively read some of the online tutorials, like this one: https://replicajunction.github.io/tag/psadt/

  • Kyle
    Participant
    Post count: 14

    Thank you!

  • Kyle
    Participant
    Post count: 14

    got it working, can be closed, thanks!

You must be logged in to reply to this topic.