Jacob

//Jacob
Jacob

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Jacob
    Participant
    Post count: 7

    Okay, so in the end I wasn’t able to get this cmdlet to work. It kept erroring out. I was on the verge of making a batch file for every shortcut and replacing the shortcuts with that file (just to make sure every user had the correct settings in HKCU before launching any of the applications) when I found this article: https://blogs.technet.microsoft.com/deploymentguys/2011/05/31/deploying-custom-registry-settings-for-office-2010/

    So I went with that. It works pretty well and I just need to modify HKLM.

  • Jacob
    Participant
    Post count: 7

    Huh? I can make an MSI with AdminStudio, it just sucks because it’s hard to repair the keys unless you do some terrible ActiveSetup modifications.

    I managed to get the REG_BINARY thing working… turns out what it didn’t like was the -SID $UserProfile.SID bit, which is odd. Now the scriptblock is failing because it thinks I’m trying to declare “ContinueOnError” for one of the Set-RegistryKey commands. Very weird stuff here.

  • Jacob
    Participant
    Post count: 7

    Okay, cool! One thing I’d suggest is that the action be written as:

    Execute-MSI -Action Install -Path $dirFiles\yourdirectory2\yourmsi2 -Transform $dirFiles\yourdirectory2\yourmst2
    (double quotes instead of single quotes as the single quotes will interpret the path as literal… I was reminded of this the hard way today)

    I’ll use this from now on! Thanks!!!

Viewing 3 posts - 1 through 3 (of 3 total)