Kristian

//Kristian
Kristian

Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Kristian
    Participant
    Post count: 3

    Turns out, I suck at formatting 😛

    • Kristian
      Participant
      Post count: 3

      Since I can’t find a way to use the grave-accent in this forum, I replaced it with the number 1, you’ll have to replace all occurences of 1 to a grave-accent for this to work:

      Execute-MSI -Action Install -Path "$dirFiles\InLoox_PM_WorkgroupEnterprise_825.msi” -Parameters "CMDLINE=1”/clientinstall connectionfile=1”1”$dirFiles\inlooxmo_connect.info1”1” folder=1”1”${Env:ProgramFiles(x86)}\InLoox\InLoox PM1"1”1” /quiet ALLUSERS=2"

  • Kristian
    Participant
    Post count: 3

    First of all, the quotes are all over the place, and therefore PowerShell doesn’t know when the command starts and stops. It also will not pass the quotation marks on to msiexec. The parantheses in “Program Files (x86)” can also create issues.

    Let’s start with the command in the script, I’ll replace the quotes with brackets, so you can see what’s wrong:

    msiexec /i {C:\TEMP\Toolkit\Files\InLoox_PM_WorkgroupEnterprise_825.msi} CMDLINE={/clientinstall connectionfile=}{......

    The CMDLINE option is outside the quotes, and powershell will either fail, or exclude everything after the first set of quotes.

    Try this, I have escaped quotation marks we want to send on with grave-accent, and replaced the folder path with an environment variable:

    <pre class=”brush: powershell; gutter: true; first-line: 1; highlight: []; html-script: false”>Execute-MSI -Action Install -Path "$dirFiles\InLoox_PM_WorkgroupEnterprise_825.msi” -Parameters "CMDLINE=”/clientinstall” connectionfile=”$dirFiles\inlooxmo_connect.info” folder=”${Env:ProgramFiles(x86)}\InLoox\InLoox PM" /quiet ALLUSERS=2"

    If the installer needs all the crazy quotes:

    <pre class="brush: powershell; gutter: true; first-line: 1; highlight: []; html-script: false">Execute-MSI -Action Install -Path &quot;$dirFiles\InLoox_PM_WorkgroupEnterprise_825.msi” -Parameters &quot;CMDLINE=”/clientinstall connectionfile=”$dirFiles\inlooxmo_connect.info” folder=”${Env:ProgramFiles(x86)}\InLoox\InLoox PM&quot;”`” /quiet ALLUSERS=2"

    • This reply was modified 2 years, 3 months ago by  Kristian.
    • This reply was modified 2 years, 3 months ago by  Kristian.
    • This reply was modified 2 years, 3 months ago by  Kristian.
    • This reply was modified 2 years, 3 months ago by  Kristian.
Viewing 3 posts - 1 through 3 (of 3 total)